Riskreporter app unavailable for Android users after update
Incident Report for Pharius
Resolved
This incident was resolved on Friday 22.30 CET
Posted Apr 15, 2024 - 09:15 CEST
Investigating
We are currently investigating this issue.
Posted Apr 12, 2024 - 17:06 CEST
This incident affected: RiskReporter.